cisco思科交换机下令参考大全,分享给个体需要的盆友们

cisco思科交换机下令参考大全,分享给个体需要的盆友们

高并发性能测试,it人员必备技能

1.设置主机名/系统名

IOS:switch(config)# hostname "hostname"

CLI:switch(enable) set system name name-string

2.设置登录口令

IOS:switch(config)# enable password level 1 password

CLI:switch(enable) set password

switch(enable) set enalbepass

3.设置远程接见

IOS:switch(config)# interface vlan 1

switch(config-if)# ip address ip-address netmask

switch(config-if)# ip default-gateway ip-address

CLI:switch(enable) set interface sc0 ip-address netmask broadcast-address

switch(enable) set interface sc0 vlan

switch(enable) set ip route default gateway

4.启用和浏览 CDP 信息

IOS:switch(config-if)# cdp enable

switch(config-if)# no cdp enable

CLI:switch(enable) set cdp {enable|disable} module/port

5.查看 Cisco 毗邻装备的 CDP 通告

IOS:switch# show cdp interface [type modle/port]

switch# show cdp neighbors [type module/port] [detail]

CLI:switch(enable) show cdp neighbors[module/port] [vlan|duplex|capabilities|detail]

6.端口形貌

IOS:switch(config-if)#description escription-string

CLI:switch(enable)set port name module/number description-string

7.设置端口速率

IOS:switch(config-if)# speed{10|100|auto}

CLI:switch(enable) set port speed moudle/number {10|100|auto}

switch(enable) set port speed moudle/number {4|16|auto}

8.设置以太网的链路模式

IOS:switch(config-if)# duplex {auto|full|half}

CLI:switch(enable) set port duplex module/number {full|half}

9.设置静态 VLAN

IOS:switch# vlan database

switch(vlan)# vlan vlan-num name vla

switch(vlan)# exit

switch# configure teriminal

switch(config)#interface interface module/number

switch(config-if)# switchport mode access

switch(config-if)# switchport access vlan vlan-num

switch(config-if)# end

CLI:switch(enable) set vlan vlan-num [name name]

switch(enable) set vlan vlan-num mod-num/port-list

10.设置 VLAN 中继线

IOS:switch(config)# interface interface mod/port

switch(config-if)# switchport mode trunk

switch(config-if)#switchport trunk encapsulation {isl|dotlq}

switch(config-if)# switchport trunk allowed vlan remove vlan-list

switch(config-if)# switchport trunk allowed vlan add vlan-list

CLI:switch(enable)set trunk module/port [on|off|desirable|auto|nonegotiate]

Vlan-range [isl|dotlq|dotl0|lane|negotiate]

11.设置 VTP 治理域

IOS:switch# vlan database

switch(vlan)# vtp domain domain-name

CLI:switch(enable) set vtp [domain domain-name]

12.设置 VTP 模式

IOS:switch# vlan database

switch(vlan)# vtp domain domain-name

switch(vlan)# vtp {sever|cilent|transparent}

switch(vlan)# vtp password password

CLI:switch(enable) set vtp [domain domain-name]

[mode{ sever|cilent|transparent }][password password]

13.设置 VTP 版本

IOS:switch# vlan database

switch(vlan)# vtp v2-mode

CLI:switch(enable) set vtp v2 enable

14.启动 VTP 剪裁

IOS:switch# vlan database

switch(vlan)# vtp pruning

CLI:switch(enable) set vtp pruning enable

15.设置以太信道

IOS:switch(config-if)# port group group-number [distribution {source|destination}]

CLI:switch(enable) set port channel moudle/port-range mode{on|off|desirable|auto}

16.调整根路径成本

IOS:switch(config-if)#spanning-tree [vlan vlan-list] cost cost

CLI:switch(enable)set spantree portcost moudle/port cost

switch(enable)set spantree portvlancost moudle/port [cost cost][vlan-list]

17.调整端口 ID

IOS:switch(config-if)#spanning-tree[vlan vlan-list]port-priority port-priority

CLI:switch(enable)set spantree portpri {mldule/port}priority

switch(enable)set spantree portvlanpri {module/port}priority [vlans]

18.修改 STP 时钟

IOS:switch(config)# spanning-tree [vlan vlan-list] hello-time seconds

switch(config)#spanning-tree [vlan vlan-list] forward-time seconds

switch(config)#spanning-tree [vlan vlan-list] max-age seconds

CLI:switch(enable) set spantree hello interval[vlan]

switch(enable) set spantree fwddelay delay [vlan]

switch(enable) set spantree maxage agingtiame[vlan]

19.启用或禁用 Port Fast 特征

IOS:switch(config-if)#spanning-tree portfast

CLI:switch(enable)set spantree portfast {module/port}{enable|disable}

20.启用或禁用 UplinkFast 特征

IOS:switch(config)#spanning-tree uplinkfast [max-update-rate pkts-per-second]

CLI:switch(enable)set spantree uplinkfast {enable|disable}[rate update-rate] [all-protocols

off|on]

为了将交流机设置成一个集群的下令交流机,首先要给治理接口分配一个 IP 地址,然后使用下列下令:

switch(config)# cluster enable cluster-name

21. 为了从一条中继链路上删除 VLAN,可使用下列下令:

switch(enable) clear trunk module/port vlan-range

22. 用 show vtp domain 显示治理域的 VTP 参数.

23. 用 show vtp statistics 显示治理域的 VTP 参数.

24. 在 Catalyst 交流机上界说 TrBRF 的下令如下:

switch(enable) set vlan vlan-name [name name] type trbrf bridge bridge-num[stp {ieee|ibm}]

25. 在 Catalyst 交流机上界说 TrCRF 的下令如下:

switch (enable) set vlan vlan-num [name name] type trcrf {ring hex-ring-num|decring

decimal-ring-num} parent vlan-num

26. 在确立好 TrBRF VLAN 之后,就可以给它分配交流机端口.对于以太网交流,可以接纳如下下令给 VLAN

分配端口:

switch(enable) set vlan vlan-num mod-num/port-num

27. 下令 show spantree 显示一个交流机端口的 STP 状态.

28. 设置一个 ELAN 的 LES 和 BUS,可以使用下列下令:

ATM (config)# interface atm number.subint multioint

ATM(config-subif)# lane serber-bus ethernet elan-name

29. 设置 LECS:

ATM(config)# lane database database-name

ATM(lane-config-databade)# name elan1-name server-atm-address les1-nsap-address

ATM(lane-config-databade)# name elan2-name server-atm-address les2-nsap-address

ATM(lane-config-databade)# name ...

30. 确立完数据库后,必须在主接口上启动 LECS.

下令如下: ATM(config)# interface atm number

ATM(config-if)# lane config database database-name

ATM(config-if)# lane config auto-config-atm-address

31. 将每个 LEC 设置到一个差别的 ATM 子接口上.下令如下:

ATM(config)# interface atm number.subint multipoint

ATM(config)# lane client ethernet vlan-num elan-num

32. 用 show lane server 显示 LES 的状态.

33. 用 show lane bus 显示 bus 的状态.

34. 用 show lane database 显示 LECS 数据库可内容.

35. 用 show lane client 显示 LEC 的状态.

36. 用 show module 显示已安装的模块列表.

37. 用物理接口确立与 VLAN 的毗邻:

router# configure terminal

router(config)# interface media module/port

router(config-if)# description description-string

router(config-if)# ip address ip-addr subnet-mask

router(config-if)# no shutdown

38. 用中继链路来确立与 VLAN 的毗邻:

router(config)# interface module/port.subinterface

router(config-ig)# encapsulation[isl|dotlq] vlan-number

router(config-if)# ip address ip-address subnet-mask

39. 用 LANE 来确立与 VLAN 的毗邻:

router(config)# interface atm module/port

router(config-if)# no ip address

router(config-if)# atm pvc 1 0 5 qsaal

router(config-if)# atm pvc 2 0 16 ilni

router(config-if)# interface atm module/port.subinterface multipoint

router(config-if)# ip address ip-address subnet-mask

router(config-if)# lane client ethernet elan-num

router(config-if)# interface atm module/port.subinterface multipoint

交换机链路聚合最常用场景分析,记住一张表格即可

router(config-if)# ip address ip-address subnet-name

router(config-if)# lane client ethernet elan-name

router(config-if)# ...

40. 为了在路由处理器上举行动态路由设置,可以用下列 IOS 下令来举行:

router(config)# ip routing

router(config)# router ip-routing-protocol

router(config-router)# network ip-network-number

router(config-router)# network ip-network-number

41. 设置默认路由: switch(enable) set ip route default gateway

42. 为一个路由处理器分配 VLANID,可在接口模式下使用下列下令:

router(config)# interface interface number

router(config-if)# mls rp vlan-id vlan-id-num

43. 在路由处理器启用 MLSP: router(config)# mls rp ip

44. 为了把一个外置的路由处理器接口和交流机安置在同一个 VTP 域中:

router(config)# interface interface number

router(config-if)# mls rp vtp-domain domain-name

45. 查看指定的 VTP 域的信息: router# show mls rp vtp-domain vtp domain name

46. 要确定 RSM 或路由器上的治理接口,可以在接口模式下输入下列下令:

router(config-if)#mls rp management-interface

47. 要磨练 MLS-RP 的设置情形: router# show mls rp

48. 磨练特定接口上的 MLS 设置:router# show mls rp interface interface number

49. 为了在 MLS-SE 上设置流掩码而又不想在任一个路由处理器接口上设置接见列表:

set mls flow [destination|destination-source|full]

50. 为使 MLS 和输入接见列表可以兼容,可以在全局模式下使用下列下令:

router(config)# mls rp ip input-acl

51. 当某个交流机的第 3 层交流失效时,可在交流机的特权模式下输入下列下令:

switch(enable) set mls enable

52. 若想改变老化时间的值,可在特权模式下输入以下下令:

switch(enable) set mls agingtime agingtime

53. 设置快速老化:switch(enable) set mls agingtime fast fastagingtime pkt_threshold

54. 确定那些 MLS-RP 和 MLS-SE 介入了 MLS,可先显示交流机引用列表中的内容再确定:

switch(enable) show mls include

55. 显示 MLS 高速缓存纪录: switch(enable) show mls entry

56. 用下令 show in arp 显示 ARP 高速缓存区的内容。

57. 要把路由器设置为 HSRP 备份组的成员,可以在接口设置模式下使用下面的下令:

router(config-if)# standby group-number ip ip-address

58. 为了使一个路由器重新恢复转发路由器的角色,在接口设置模式下:

router(config-if)# standy group-number preempt

59. 接见时间和保持时间参数是可设置的:

router(config-if)# standy group-number timers hellotime holdtime

60. 设置 HSRP 跟踪:router(config-if)# standy group-number track type-number interface-priority

61. 要显示 HSRP 路由器的状态:router# show standby type-number group brief

62. 用下令 show ip igmp 确定当选的查询器。

63. 启动 IP 组播路由选择:router(config)# ip muticast-routing

64. 启动接口上的PIM: dalllasr1>(config-if)# ip pim {dense-mode|sparse-mode|sparse-dense-mode}

65. 启动希罕-浓密模式下的 PIM:

router# ip multicast-routing

router# interface type number

router# ip pim sparse-dense-mode

66. 核实 PIM 的设置: dallasr1># show ip pim interface[type number] [count]

67. 显示 PIM 邻人: dallasr1># show ip neighbor type number

68. 为了设置 RP 的地址,下令如下:

dallasr1># ip pim rp-address ip-address [group-access-list-number][override]

69. 选择一个默认的 RP: dallasr1># ip pim rp-address

通告 RP 和它所服务的组局限:

dallasr1># ip pim send-rp-announce type number scope ttl group-list access-list-number

为治理局限组通告 RP 的地址:

dallasr1># ip pim send-rp-announce ethernet0 scope 16 group-list1

dallasr1># access-list 1 permit 266.0.0.0 0.255.255.255

设定一个 RP 映像署理:dallasr1># ip pim send-rp-discovery scope ttl

核实组到 RP 的映像:

dallasr1># show ip pim rp mApping

dallasr1># show ip pim rp [group-name|group-address] [mapping]

70. 在路由器接口上用下令 ip multicast ttl-threshold ttl-value 设定 TTL 阀值:

dallasr1>(config-if)# ip multicast ttl-threshold ttl-value

71. 用 show ip pim neighbor 显示 PIM 邻人表。

72. 显示组播通讯路由表中的各条纪录:

dallasr1>show ip mroute [group-name|group-address][scoure][summary][count][active kbps]

73. 要纪录一个路由器接受和发送的所有 IP 组播包:

dallasr1> #debug ip mpacket [detail] [access-list][group]

74. 要在 CISCO 路由器上设置 CGMP: dallasr1>(config-if)# ip cgmp

75.设置一个组播路由器,使之加入某一个特定的组播组:

dallasr1>(config-if)# ip igmp join-group group-address

76. 关闭 CGMP: dallasr1>(config-if)# no ip cgmp

77. 启动交流机上的 CGMP: dallasr1>(enable) set cgmp enable

78. 核实 Catalyst 交流机上 CGMP 的设置情形:

catalystla1>(enable) show config

set prompt catalystla1>

set interface sc0 192.168.1.1 255.255.255.0

set cgmp enable

79. CGMP 脱离的设置: Dallas_SW(enable) set cgmp leave

80. 在 Cisco 装备上修改控制端口密码:

R1(config)# line console 0

R1(config-line)# login

R1(config-line)# password Lisbon

R1(config)# enable password Lilbao

R1(config)# login local

R1(config)# username student password cisco

81. 在 Cisco 装备上设置控制台及 vty 端口的会话超时:

R1(config)# line console 0

R1(config-line)# exec-timeout 5 10

R1(config)# line vty 0 4

R1(config-line)# exec-timeout 5 2

82. 在 Cisco 装备上设定特权级:

R1(config)# privilege configure level 3 username

R1(config)# privilege configure level 3 copy run start

R1(config)# privilege configure level 3 ping

R1(config)# privilege configure level 3 show run

R1(config)# enable secret level 3 cisco

83. 使用下令 privilege 可界说在该特权级下使用的下令:

router(config)# privilege mode level level command

84. 设定用户特权级:

router(config)# enable secret level 3 dallas

router(config)# enable secret san-fran

router(config)# username student password cisco

85. 标志设置与显示:

R1(config)# banner motd ‘unauthorized access will be prosecuted!'

86. 设置 vty 接见:

R1(config)# access-list 1 permit 192.168.2.5

R1(config)# line vty 0 4

R1(config)# access-class 1 in

87. 设置 HTTP 接见:

Router3(config)# access-list 1 permit 192.168.10.7

Router3(config)# ip http sever

Router3(config)# ip http access-class 1

Router3(config)# ip http authentication local

Router3(config)# username student password cisco

88. 要启用 HTTP 接见,请键入以下下令: switch(config)# ip http sever

89. 在基于 set 下令的交流机上用 setCL1 启动和核实端口平安:

switch(enable) set port security mod_num/port_num...enable mac address

switch(enable) show port mod_num/port_num

在基于 CiscoIOS 下令的交流机上启动和核实端口平安:

switch(config-if)# port secure [mac-mac-count maximum-MAC-count]

switch# show mac-address-table security [type module/port]

90. 用下令 access-list 在尺度通讯量过滤表中确立一条纪录:

Router(config)# access-list access-list-number {permit|deny} source-address

[source-address]

91. 用下令 access-list 在扩展通讯量过滤表中确立一条纪录:

Router(config)#access-list access-list-number

{permit|deny{protocol|protocol-keyword}}{source source-wildcard|any}{destination

destination-wildcard|any}[protocol-specific options][log]

92. 对于带内路由更新,设置路由更新的最基本的下令花样是:

R1(config-router)#distribute-list access-list-number|name in [type number]

93. 对于带外路由更新,设置路由更新的最基本的下令花样是:

R1(config-router)#distribute-list access-list-number|name out [interface-name]

routing-process| autonomous-system-number

94. set snmp 下令选项:

set snmp community {read-only|ready-write|read-write-all}[community_string]

95. set snmp trap 下令花样如下:

set snmp trap {enable|disable} [all|moudle|classis|bridge|repeater|

auth|vtp|ippermit|vmps|config|entity|stpx]

set snmp trap rvcr_addr rcvr_community

96. 启用 SNMP chassis 陷阱: Console>(enable) set snmp trap enable chassis

97. 启用所有 SNMP chassis 陷阱: Console>(enable) set snmp trap enable

98. 禁用 SNMP chassis 陷阱: Console>(enable) set snmp trap disable chassis

99. 给 SNMP 陷阱吸收表加一条纪录: Console>(enable) set snmp trap 192.122.173.42 public

100. show snmp 输出效果。

101. 下令 set snmp rmon enable 的输出效果。

102. 显示 SPAN 信息:Consile> show span

正规的运维工作是什么的?

分享到 :
相关推荐

发表评论

登录... 后才能评论