原创:思科交换机常用设置

原创:思科交换机常用设置

谷歌宣布因受疫情影响该公司将放弃谷歌浏览器v82版直接开发v83系列

一、交流机的设置方式

1、Console

将设置电缆的DB-9(或DB-25)孔式插头 接到要对交流机举行设置的微机或终端的串口上。

首先启动超级终端,点击windows的最先→程序→附件→通讯→超级终端,启动超级终端。

凭据提醒输入毗邻形貌名称后确定,在选择毗邻时使用响应的COM口(可通过装备治理器查看COM口)后单击"确定"按钮,在弹出的COM1属性窗口中单击"还原为默认值"按钮后单击"确定"按钮。

原创:思科交流机常用设置

 

原创:思科交流机常用设置

 

原创:思科交流机常用设置

 

2、telnet

switch>enable

switch#configure terminal

switch(conf)#enable password cisco //以cisco为特权模式密码(使用telnet必须设置特权密码)

switch(conf)#line vty 0 4 //设置0-4个用户可以telnet远程登陆

switch(conf-line)#login

switch(conf-line)#password 123456

//以123456为远程登录的用

户密码

以上下令打开交流机telnet功效,至此可以通过telnet下令接见并治理此交流机。

二、装备治理

1、设置交流机名称

switch(conf)#hostname CoreSwitch

CoreSwitch(conf)#

2、保留设置

switch#write

或 //特权模式保留设置

switch#copy run start

3、交流机重启

switch#reload

4、恢复出厂默认恢复下令

switch#write erase

switch#reload

三、端口设置

1、端口设置

switch (conf)#interface g1/1 //以第1块板卡的1号端口为例

switch (conf-if)#duplexfull/half/auto //更改双工模式

switch (conf-if)#speed 10/100/1000 //更改端口速率、

switch (conf-if)#shutdown //关闭端口

switch (conf-if)#no shutdown //启用端口

2、端口聚合

端口聚合也叫做以太通道(ethernet channel),主要用于交流机之间毗邻。由于两个交流机之间有多条冗余链路的时刻,STP会将其中的几条链路关闭,只保留一条,这样可以制止二层的环路发生。然则,失去了路径冗余的优点,由于STP的链路切换会很慢,在50s左右。使用以太通道的话,交流机遇把一组物理端口联合起来,做为一个逻辑的通道,也就是channel-group,这样交流机遇以为这个逻辑通道为一个端口,同时提高链路带宽。

Switch#config

Switch (Config)#interface range g1/2-3 //进入第1块板卡的2、3号端口

Switch (Config-Port-Range)#port-group 1 mode on //设置端口聚合方式为手动

Switch (Config-Port-Range)#exit

Switch (Config)#interface port-channel 1 //进入聚合端口

Switch (Config-If-Port-Channel1)#swithport mode trunk //设置聚合端口为trunk

Switch (Config-If-Port-Channel1)#no shutdown //启用聚合端口

四、VLAN虚拟局域网

VLAN(Virtual Local Area Network)的中文名为"虚拟局域网"。VLAN是一种将局域网装备从逻辑上划分成一个个网段,从而实现虚拟事情组的数据交流手艺。注重:若是交流机接口处于no switchport状态属于三层接口,无法加入到vlan中,需要进入端口执行switchport下令。

例:switch(config)# interface g1/1

switch(config-if)# switchport

1、设置VLAN

switch# configure terminal //进入全局设置模式

switch(config)# vlan 10 //设置VLAN 10

switch(config-vlan)# name JK // VLAN命名为JK

switch(config-vlan)#exit

switch(config)# interface g1/1 //进入指定端口

switch(config-if)# switchprot access vlan 10 //将端口划入VLAN

端口选择技巧:

switch(config)# interface range g1/1–5 //选择延续多个端口

switch(config)# interface range g1/6-8,1/9-11,1/22  //将不延续多个端口加入到Vlan中

2、设置TRUNK透传模式

详解 UML 用例图画法 & 用例说明方式

switch(config)# interface g1/1 //进入指定端口

switch(config-if)# switchport mode trunk //设置接口为TRUNK模式

//默认设置完trunk后,允许所有VLAN ID通过

switch(config-if)# switchport trunk allowed vlan remove 20

//设置移除trunk允许通过的VLAN ID

switch(config-if)# switchport trunk allowed vlan add 20

//设置添加trunk允许通过的VLAN ID

五、IP协议设置

1、为VLAN设置IP地址

switch(config)#interface VLAN 233 //进入VLAN虚拟接口

switch(config-if)#ip address 192.168.1.1 255.255.255.0 //设置IP地址及掩码

switch(config-if)#no shutdown //启用接口

2、添加静态路由

switch(config)#ip route 目的地址网段 目的网络子网掩码 下一条地址

//设置视图下设置

例:switch(config)#ip route 192.168.6.0 255.255.255.0 192.168.2.2

六、组播

1、PIM-SM

PIM-SM(Protocol Independent Multicast,Sparse Mode)即与协议无关的组播希罕模式,属于希罕模式的组播路由协议。PIM-SM主要用于组成员漫衍相对涣散、局限较广、大规模的网络。

与麋集模式的扩散/剪枝差别,PIM-SM协议假定所有的主机都不需要吸收组播数据包,只有主机明确指定需要时,PIM-SM路由器才向它转发组播数据包。

PIM-SM协议中,通过设置汇聚点RP(Rendezvous Point)和自举路由器BSR(Bootstrap Router),向所有PIM-SM路由器通告组播信息,并行使路由器的加入/剪枝信息,建立起基于RP的共享树RPT(RP-rooted shared tree)。从而削减了数据报文和控制报文占用的网络带宽,降低路由器的处置开销。组播数据沿着共享树流到该组播组成员所在的网段,当数据流量到达一定水平,组播数据流可以切换到基于源的最短路径树SPT,以削减网络延迟。PIM-SM不依赖于特定的单播路由协议,而是使用现存的单播路由表举行RPF检查。

运行PIM-SM协议,需要设置候选RP和BSR,BSR卖力网络候选RP发来的信息,并把它们广播出去。

2、PIM-DM

PIM-DM(Protocol Independent Multicast,Dense Mode)属于麋集模式的组播路由协议。PIM-DM适用于小型网络,在这种网络环境下,组播组的成员相对对照麋集。PIM-DM的事情历程可以归纳综合为:邻人发现、扩散、剪枝历程、嫁接阶段。

3、设置举例

1、使能组播路由

switch(conf)#ip multicast-routing

2、进入接口

switch(conf)#interface Vlan233

3、在接口上启动PIM SM或DM

switch(conf-if)# ip pim sparse-dense-mode //希罕麋集模式

ip pim sparse-mode//希罕模式

ip pim dense-mode//麋集模式

若是是二层交流机,则只需在系统视图下设置igmp-snooping即可

七、双机热备

switch(conf)#redundancy //进入热备设置视图

switch(conf-red)#main-cpu //设置同步设置文件

switch(conf-red)mode sso //设置热备模式为SSO

八、查看交流机信息及排错常用下令

1、Show

switch(conf)#show run //查看当前运行设置信息

switch(conf)#show vlan brief //显示VLAN设置信息

switch(conf)#show ip route //显示路由表

switch(conf)#show interface XX //显示指定端口信息

switch(conf)#Show interfaces //显示设置在路由器和接见服务器上所有接口的统计信息

switch(conf)#Show ip interface //列出一个接口的IP信息和状态的小结

switch(conf)#Show version //显示系统硬件的设置,软件的版本,设置文件的名称和泉源及指导映像

switch(conf)#Show memory //显示路由器内存的巨细,包罗空闲内存的巨细

switch(conf)# Show processes //显示路由器的历程

switch(conf)#Show flash //显示闪存的结构和内容信息

2、debug

对于路由器和交流机的故障诊断,只用一个 show 下令是远远不够的。而 debug 下令往往能够辅助我们看清楚背后的故障缘故原由。

Switch#debug // 显示所有可用的debug指令及简短的说明

Switch #show debugging //显示当前各个调试开关的状态

Switch #debug all //打开系统所有的调试开关

Switch #undebug all //关闭所有的调试开关

Switch #debug arp //打开ARP调试开关

Switch #debug igmp //打开IGMP调试开关

Switch #debug ip //打开IP调试开关

Switch #debug multicast //打开多播数据流调试开关

Switch #debug pim //打开PIM调试开关

Switch #debug vlan //打开VLAN调试开关

基准测试显示新版Microsoft Edge性能要比经典版高出10%左右

分享到 :
相关推荐

发表评论

登录... 后才能评论